Sparx Learning

Sparx Science slow to load
Resolved·Degraded performance

Sparx Science is now fully operational.

Thu, Mar 27, 2025, 09:48 AM
(2 months ago)
·
Affected components
Updates

Resolved

Sparx Science is now fully operational.

Thu, Mar 27, 2025, 09:48 AM

Monitoring

We've now fixed this issue - both students and teachers should be able to access everything as normal.

Thu, Mar 27, 2025, 09:39 AM

Investigating

Sparx Science is still slow to load and some features might not be available for students and teachers. We're working on finding a solution to this as soon as possible. Apologies for any inconvenience this may have caused.

Thu, Mar 27, 2025, 09:28 AM(10 minutes earlier)

Investigating

Sparx Science is currently slow to load and some features may not be available for students and teachers. We're investigating this urgently.

Thu, Mar 27, 2025, 09:08 AM(20 minutes earlier)